IBMIM and Firefox 10

I posted IBM Installation Manager cannot find a supported browser a little while ago about trying to get the IBM Installation Manager (IBMIM) running with Firefox 10. Well today it tripped me up again but this time there was an additional line in <install_root>/launchpad/browser.sh which I have highlighted in blue.

This line will need to be removed as well as adding the line in red and voila.

supportedFirefoxVersion()
{
        case “$*” in
                *Firefox\ [1-9].*) return 0;;
                *Firefox/[1-9].*) return 0;;
#               *Firefox*) return 1;;
                *Firefox\ [1-9][0-9].*) return 0;;

Advertisements